I've really gone and done it now...

Are you stuck at a particular point, can't find the answer elsewhere, here's the place to ask.
Posts: 2
Joined: Mon Jun 15, 2015 9:29 pm

I've really gone and done it now...

Postby 2of2jakes » Mon Jun 15, 2015 10:19 pm

Ok, so lets start at the start..
Bought a brand new wink hub....used the app to set it up, and was able to talk to my zwave DZPA1 with no problem..
but ..I've got a little Linux experience, (not alot but setup OpenHab on a ubuntu machine to play with), and a very curious mind..so I thought 'rooting a wink' would be good fun and I'd learn something..
I read up a bit and soon found that the the 'curl methods' don't work on the new WH. I watched the youtube video on the '"UART GND point to the 29th pin on the NAND" (I found the link on xda). And figured "hey I can do that!"..So I got myself a UART cable & heated up the soldering iron!! I learned that minicom on a MAC is really alot like telix from days of my youth ;)...Also learned my hands shake abit & my sense of timing is a bit off...
I got pin 29 to ground, but at the wrong time.....
Here's what I get:

Code: Select all

Please append a correct "root=" boot option; here are the available partitions:
1f00            3072 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02           28672 mtdblock2 (driver?)
1f03            8192 mtdblock3 (driver?)
1f04            8192 mtdblock4 (driver?)
1f05           78848 mtdblock5 (driver?)
fe00           75144 ubiblka (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[<8002b9d0>] (dump_backtrace+0x0/0x110) from [<802d90e0>] (dump_stack+0x18/0x1c)
 r7:80023a14 r6:00008000 r5:83c13000 r4:803dfd58
[<802d90c8>] (dump_stack+0x0/0x1c) from [<802d915c>] (panic+0x78/0xfc)
[<802d90e4>] (panic+0x0/0xfc) from [<80008ee8>] (mount_block_root+0x25c/0x2ac)
 r3:00000000 r2:00000001 r1:83c23f78 r0:8035bd98
[<80008c8c>] (mount_block_root+0x0/0x2ac) from [<80009038>] (prepare_namespace+0x94/0x18c)
[<80008fa4>] (prepare_namespace+0x0/0x18c) from [<800084f8>] (kernel_init+0x128/0x170)
 r5:80022248 r4:803def40
[<800083d0>] (kernel_init+0x0/0x170) from [<80046f38>] (do_exit+0x0/0x6a4)
 r5:800083d0 r4:00000000

And she freezes..
I read a TON of cloneNum3 posts (as in this entire forum...and thank you for the effort!) and here's what I've learned & done so far:
I have root via the UART.
I know this because: I get the "==>" prompt. At that time I enter:

Code: Select all

setenv bootargs 'noinitrd console=ttyAM0,115200 rootfstype=ubifs ubi.mtd=2 root=ubi0:rootfs rw gpmi init=/bin/sh'
nand read ${loadaddr} app-kernel 0x00400000 && bootm ${loadaddr}

Then I get the root prompt "#"
I tried to get the updater to do its magic, but

Code: Select all


doesn't run properly, I get:

Code: Select all

/ # /root/platform/upgrade.sh
+ echo 'Press enter to cancel update...'
Press enter to cancel update...
+ read -t2 stdin
+ '[' 1 = 0 ']'
+ set_rgb 100 100 0 0 0 0 flash 250000
/root/platform/upgrade.sh: line 14: set_rgb: command not found
+ source /root/platform/platform.sh
++ set -x
+++ grep database
+++ mount
mount: no /proc/mounts
++ dbcheck=
++ '[' '' == '' ']'
++ ubiattach -p /dev/mtd3
/root/platform/platform.sh: line 10: ubiattach: command not found
++ '[' 0 '!=' 127 ']'
++ ubiformat /dev/mtd3 -y -q
/root/platform/platform.sh: line 13: ubiformat: command not found
++ ubiattach -p /dev/mtd3
/root/platform/platform.sh: line 14: ubiattach: command not found
++ mknod /dev/ubi1 c 252 0
mknod: /dev/ubi1: File exists
++ ubimkvol /dev/ubi1 -m -N database                                                                                                                           
/root/platform/platform.sh: line 16: ubimkvol: command not found                                                                                               
++ '[' 0 '!=' 127 ']'                                                                                                                                           
++ echo 'could not attach db. Exit.'                                                                                                                           
could not attach db. Exit.                                                                                                                                     
++ set_rgb 200 0 0                                                                                                                                             
/root/platform/platform.sh: line 21: set_rgb: command not found                                                                                                 
++ source /root/platform/platform.config                                                                                                                       
+++ SCRIPT_VERSION=UPDATE                                                                                                                                       
+++ sw_pkg_url=https://hub-updates.winkapp.com                                                                                                                 
+++ alt_pkg_url=https://wink-hub-images.s3.amazonaws.com                                                                                                       
++++ cat /database/cf_url                                                                                                                                       
cat: can't open '/database/cf_url': No such file or directory                                                                                                   
+++ eval tmp=                                                                                                                                                   
++++ tmp=                                                                                                                                                       
+++ '[' '' '!=' '' ']'                                                                                                                                         
++++ cat /database/cf_build                                                                                                                                     
+++ eval build=00.01                                                                                                                                           
++++ build=00.01                                                                                                                                               
+++ '[' 00.01 '!=' '' ']'                                                                                                                                       
+++ board_id=00.01                                                                                                                                             
+++ sw_pkg_url=https://hub-updates.winkapp.com/00.01                                                                                                           
+++ alt_pkg_url=https://wink-hub-images.s3.amazonaws.com/00.01                                                                                                 
+++ group_id=0                                                                                                                                                 
+++ fparts=4                                                                                                                                                   
+++ ntpserver1=0.rhel.pool.ntp.org                                                                                                                             
+++ ntpserver2=1.rhel.pool.ntp.org                                                                                                                             
+++ '[' UPDATE '!=' APP ']'                                                                                                                                     
+++ canupdate[0]=1                                                                                                                                             
+++ canupdate[1]=1                                                                                                                                             
+++ upgrade_boot=1                                                                                                                                             
+++ app_boot=0                                                                                                                                                 
+++ num_bootloaders=2                                                                                                                                           
+++ eth_dev=wlan0                                                                                                                                               
+++ eth_timeout=60                                                                                                                                             
+++ ntpd_retry=3                                                                                                                                               
+++ curl_args='--cacert /etc/ssl/certs/ca-certificates.crt --retry 5'                                                                                           
++ '[' UPDATE '!=' APP ']'                                                                                                                                     
++ sleep 5                                                                                                                                                     
++ exit 0                                                                                                                                                       
/ #

Which I think is telling me that I don't have networking running..plus ping yields

Code: Select all

PING ( 56 data bytes                                                                                                                   
ping: sendto: Network is unreachable

So this leaves me with 2 questions:
1) How do I start networking? As close as I can get is

Code: Select all

insmod /root/wifi/dhd.ko firmware_path="/root/wifi/fw_prod.bin" nvram_path="/root/wifi/nvram.conf" iface_name=wlan0 dhd_sdiod_drive_strength=8

Which gives

Code: Select all

DHD: dongle ram size is set to 524288(orig 524288) at 0x0                                                                                                       
dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)                                                                                                             
dhd_wlfc_init(): successfully enabled bdcv2 tlv signaling, 79                                                                                                   
wlan0: Broadcom Dongle Host Driver                                                                                                                             
Dongle Host Driver, version 1.88.64 (r447771)   

And still no ping..And that bothersome "set_rgb: command not found"...I think that's a big clue as to whats going on, but I don't know..I've grabbed all the /root/wifi/<scripts> so I could readup on how networking starts, but I'm missing something & now I'm stuck :(

2) My general plan is to get networking started & let it update the all the partitions. If I leave the UART on, I can get root again, then follow cloneNum3's posts..no biggie & I don't mind practicing :)
My last question (for now) is this:Does this hub have the potential to work again?...or did I learn something else this week?

Thanks for reading!

Posts: 2
Joined: Mon Jun 15, 2015 9:29 pm

Re: I've really gone and done it now...

Postby 2of2jakes » Sun Jun 28, 2015 11:50 am

Time for an update: score --> me 1, broken tech 0

I was really over thinking the issue..I ended up firing up /root/wifi/run.sh
This started the wifi. Because I has already set upgrade = 1, the hub processed the upgrade (basically formatted all partitons except 'upgrade' and rebuilt itself..)
I had set the UART boot delay (and moved a few things to the upgrade partiton earlier) so when it rebooted, I jumped in via UART, and made the ssh modifications mentioned http://www.rootwink.com/viewtopic.php?f=8&t=8 , but using ssh not curl..yet.
Then I rebooted a few time & verified that I could access the hub via ssh & the key file...then added my key, remove the test key & deleted the key file.
I did leave the hosts file like this:

Code: Select all

#       hub-api.winkapp.com       hub-updates.winkapp.com       wink-hub-images.s3.amazonaws.com

So that I could use the api and have the light as blue...other wise the android api wouldn't work and the light was some "odd color".

The rest of the story has been following the posts on this board & editing openhab rules!!
It's all working well together.

Next step will be playing with Blink (i can't make it work..yet)

Return to “Help me, I can't do xyz”

Who is online

Users browsing this forum: No registered users and 0 guests